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This guide describes iTunes Producer 2.9 for books, Apple’s tool for preparing and sending your publications
for sale in the iBookstore, and the steps necessary to install and use iTunes Producer 2.9 for books. You use
iTunes Producer 2.9 for books to provide information about a publication, such as type, title, publisher, date,
category, authors, audience, and more, and upload asset files.

What’s New
iTunes Producer 2.9 for books contains the following enhancements:

 ● Parental advisory support for books. iTunes Producer 2.9 for books now includes the ability for you to
specify whether or not a book contains sexually explicit content. For details, see “Entering Book
Information” (page 25).

 ● Series sequence improvements. For books in a series, you can now specify the series number you want to
appear in the iBookstore. For details, see “Entering Book Information” (page 25).

 ● Enhanced screenshot assets. You can now drag multiple screenshots to the Upload Screenshot box to add
new screenshot assets for your publication. For details, see “Specifying Screenshot Assets” (page 39).

 ● Multi-Touch identification. Using iTunes Producer 2.9 for books, you can now indicate whether or not a
book is in Multi-Touch format. For details, see “Entering Book Information” (page 25).

Organization of This Document
This guide is organized as follows:

 ● “Getting Started” (page 6) provides an overview of iTunes Producer 2.9 for books, describes the system
requirements and supported formats, and outlines the steps you must take to install and start using iTunes
Producer 2.9 for books.

 ● “Creating Your Book Package” (page 12) describes how to create a book package to submit to the
iBookstore.

 ● “Describing Your Book Package” (page 24) explains how to prepare your book package for delivery to the
iBookstore by providing details about your publication, including type, title, publisher, date, category,
authors, audience, and more, and upload asset files.
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 ● “Delivering Your Book Package” (page 41) provides details on how to deliver your book package to the
iBookstore for processing and how to send Apple a log report if you encounter errors during delivery.

 ● “Featured Tasks” (page 44) features some of the top tasks you might perform using iTunes Producer 2.9
for books.

 ● “Glossary” (page 50) defines terms you’ll encounter as you read this guide.

In addition to the sections listed above, a revision history and index are provided for your reference.

Getting Additional Information
If you need to request technical assistance or would like to provide feedback about iTunes Producer 2.9 for
books, visit the Contact Us page in iTunes Connect at http://www.apple.com/itunes/go/itunesconnect/contactus
or choose Help > Submit Feedback to send an email to your iTunes Technical Account Manager.

You can also email or call the iBookstore support team Monday through Friday from 7:00 a.m. to 5:00 p.m.
(Pacific time). For comprehensive support information, use the Contact Us page on iTunes Connect.

AppleCare support is not available for this product.

For information on how to get started as a content provider to deliver books to the iBookstore, see iBookstore:
Publisher User Guide . iBookstore: Publisher User Guide also explains how to prepare and upload your books,
and some guidelines on creating your book files.

Note: Textbooks are not available in all markets.

Introduction
Getting Additional Information
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This section provides an overview of iTunes Producer 2.9 for books, including system requirements, supported
formats, and the steps you must take to install and start using iTunes Producer 2.9 for books.

What is iTunes Producer 2.9 for Books?
iTunes Producer 2.9 (iTP) for books is a tool to help you prepare publication content for sale in the iBookstore.
Using iTP, you can import your publication (book or textbook), enter book details, upload cover art and
screenshots, and send your book and all your prepared files as an iTunes Store Package (iTP package) directly
to Apple’s iBookstore.

Note: Textbooks are not available in all markets, check the Contact Us page in iTunes Connect for up-to-date
information.

System Requirements
iTunes Producer 2.9 for books requires a Macintosh with an Intel Core processor, at least 512 MB RAM, and
Mac OS X v10.6 or later installed.

Apple recommends at least 20 GB of available space (more for larger content) and a broadband Internet
connection with an upload rate of 1MB/sec or faster.

The following table lists details about the servers iTunes Producer 2.9 for books uses to deliver content to the
iBookstore. For the best upload experience, verify that all of the ports and IP addresses are accessible.

UDP PortTCP PortIP AddressServer

n/a44317.152.19.125itmsdav.apple.com

n/a443*17.152.19.127contentdelivery.itunes.apple.com

33001-335003300117.152.249.51vgr101.apple.com

33001-335003300117.152.249.52vgr102.apple.com

33001-335003300117.152.249.53vgr103.apple.com
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UDP PortTCP PortIP AddressServer

33001-335003300117.152.249.54vgr104.apple.com

33001-335003300117.152.249.55vgr105.apple.com

33001-335003300117.152.249.56vgr106.apple.com

33001-335003300117.152.249.57vgr107.apple.com

33001-335003300117.152.249.58vgr108.apple.com

33001-335003300117.172.190.141vgr301.apple.com

33001-335003300117.172.190.142vgr302.apple.com

33001-335003300117.172.190.143vgr303.apple.com

33001-335003300117.172.190.144vgr304.apple.com

33001-335003300117.172.190.145vgr305.apple.com

33001-335003300117.172.190.146vgr306.apple.com

33001-335003300117.172.190.147vgr307.apple.com

33001-335003300117.172.190.148vgr308.apple.com

44001-445004400117.152.249.101sgr201.apple.com

44001-445004400117.152.249.102sgr202.apple.com

44001-445004400117.152.249.103sgr203.apple.com

44001-445004400117.152.249.104sgr204.apple.com

44001-445004400117.152.249.105sgr205.apple.com

44001-445004400117.152.249.106sgr206.apple.com

44001-445004400117.152.249.107sgr207.apple.com

44001-445004400117.152.249.108sgr208.apple.com

44001-445004400117.172.190.101sgr401.apple.com

44001-445004400117.172.190.102sgr402.apple.com

44001-445004400117.172.190.103sgr403.apple.com

Getting Started
System Requirements
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UDP PortTCP PortIP AddressServer

44001-445004400117.172.190.104sgr404.apple.com

44001-445004400117.172.190.105sgr405.apple.com

44001-445004400117.172.190.106sgr406.apple.com

44001-445004400117.172.190.107sgr407.apple.com

44001-445004400117.172.190.108sgr408.apple.com

Notes:

 ● * Indicates a required port. To deliver content, you must open at least one of the ports.

 ● Because Apple periodically releases new versions and updates to its software, servers listed in the table
might change mid-release.

Supported Formats
iTunes Producer 2.9 (iTP) for books supports EPUB 2, EPUB 3, and Multi-Touch formats with the appropriate
file extensions (.epub and .ibooks).

Cover art (also known as a marketing image or jacket) should be at least 1400 pixels along the smaller axis and
must be a JPEG or PNG file in RGB Color mode. For an average trade paperback, this could be 1400 x 1873
minimum size, as the books are generally taller than they are wide. For best results, deliver the largest pixel
dimensions possible. When possible, match cover art to the cover contained in the book file. The 2 million
pixel maximum does not apply to the cover image.

Screenshots should be a clear picture, made on an iPad, and be a 1024 x 768, 1024 x 748, 768 x 1024, or 768
x 1004 pixel JPEG or PNG file (for an iPad 1 or 2, double for the new iPad) with the appropriate file extensions
(.jpg, .jpeg, and .png) in RGB Color mode. Optionally, you can remove the status bar.

You can use your keyboard to perform many of the same actions you perform using the mouse. With full
keyboard access, you use the Tab key, arrow keys, and Space bar to move to and select or enable items on the
screen.

Getting Started
Supported Formats
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Installing iTunes Producer 2.9 for Books
You can install and run iTunes Producer 2.9 (iTP) for books on the Mac OS X operating system. To install iTP
on Mac OS X:

1. Click the iTunes Producer link in the Deliver Your Content module:

iTunes Connect displays the iTunes Producer Software and Documentation page with installation and
documentation downloads.

2. Click the iTunes Producer 2.9 link to download the self-extracting installation package
(iTunesProducer_2.9.dmg).

3. Review the Read Before You Install iTunes Producer file.

4. Double-click the installation package (iTunesProducer.pkg) and follow the instructions that appear.

Note:When installing iTP on the Mac, before you can install the software, you must log in to your computer
as a member of the administrator group.

5. Read the installation introduction, and then click Continue.

Getting Started
Installing iTunes Producer 2.9 for Books
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6. Click Install to perform the standard installation.

The installation package installs files in your Applications folder.

Type your administrator password and click OK, if prompted.

7. Click Close.

Open the iTP application by double-clicking the iTunes Producer.app icon in the Applications folder, or
the folder you specified during a custom install. You are now ready to begin using iTP. For more information,
see “Starting iTunes Producer 2.9 for Books” (page 10) later in this section.

Starting iTunes Producer 2.9 for Books
Before you can use iTunes Producer 2.9 (iTP) for books to prepare publication content for sale in the iBookstore,
you must initialize iTP by providing your iTunes Connect login information at startup.

1. Double-click the iTunes Producer.app icon in the Applications folder.

2. Read the Software License Agreement, and then click Accept.

iTP opens the "Welcome to iTunes Producer” window.

3. Type your iTunes Connect login information (Apple ID and password) in the “Welcome to iTunes Producer”
window, and then click Next.

iTP verifies your iTunes Connect login information and stores your Apple ID and password for future iTP
operations.

Getting Started
Starting iTunes Producer 2.9 for Books
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Initializing iTP with your iTunes Connect login information is account-specific. If you share your machine
with other users with different iTunes Connect login information, you can each have your own Apple ID
and password setting for iTP.

4. Click Done.

iTP displays the “Choose an Activity” window so you can begin using iTP. For more information, see
“Creating Your Book Package” (page 12) later in this guide.

If the “Choose an Activity” window does not display any activities, you do not have an active contract with
iTunes. You must complete the contract process before you can deliver content for sale in the iBookstore.
For more information, see the Contracts, Tax and Banking module in iTunes Connect.

Notes:

 ● If you change your iTunes Connect password, you must use the "Welcome to iTunes Producer” window
to reset your Apple ID and password in iTP. To reset your Apple ID and password, choose Window > Sign
In As in iTP, and then repeat steps 2 through 4 above.

 ● The main iTP windows contain an active user button displaying the Apple ID for the currently logged in
user. Click the button to display the "Welcome to iTunes Producer” window to change or update your
Apple ID and password.

 ● Click to display this Using iTunes Producer 2.9 for Books guide.

Getting Started
Starting iTunes Producer 2.9 for Books
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The first step in preparing content for sale in the iBookstore is to create a book package containing the
publication content you want to submit. You can select the publication you want to include in a book package
from a publication (book or textbook) on your computer, an existing iTunes Store Package (iTP package), by
importing publication details from a file, or by looking up the metadata from an existing iBookstore book.

The following screenshot displays the iTP “Choose an Activity” window with the “New book” option selected.

If you do not see any of the above activities in the iTP “Choose an Activity” window, you might not have
configured iTP for book delivery. Click the active user button in the “Choose an Activity” window to display
the “Welcome to iTunes Producer” window again.

Creating a Book Package from a Publication File
You can create your book package by choosing the publication (book or textbook) you want to submit to the
iBookstore from files on your computer.

To create your book package from files on your computer:

2013-02-20   |   © 2013 Apple Inc. All Rights Reserved.

12

Creating Your Book Package



1. Click Create New Package in the “Choose an Activity” window.

The “Choose an Activity” window appears automatically when you open iTunes Producer 2.9 for books,
or you can choose File > New to display the “Choose an Activity” window from within iTunes Producer 2.9
(iTP) for books.

2. Select “New book”, and then click Next.

iTP displays an untitled iTP window with the Book pane selected so you can begin describing your
publication and entering information about the categories, authors, target audience, related products,
and rights and pricing. For more information, see “Describing Your Book Package” (page 24).

When you are sure the publication details are complete and correct, you can send your book package to iTunes
for processing. For more information, see “Delivering Your Book Package” (page 41).

Opening an Existing Package
You can create your book package by opening a previously saved iTunes Store Package (iTP package), editing
publication details, and updating the information you want to submit to the iBookstore.

To create your book package from an existing package:

1. Click Open Package in the “Choose an Activity” window.

iTP displays an Open dialog so you can select an existing iTP package.

The “Choose an Activity” window appears automatically when you open iTunes Producer 2.9 for books,
or you can choose File > New to display the “Choose an Activity” window from within iTunes Producer 2.9
(iTP) for books.

2. Select the package name containing the publication you want to include in your book, and then click
Open.

iTP opens the package and displays the Book pane.

If you previously delivered the book package to the iBookstore, you can specify new information about
the book in “What’s New in Version”.

3. Use the Book pane to add and edit publication information (for example, title and subtitle), categories,
authors, target audience, related products, and rights and pricing. For more information, see “Providing
Book Details” (page 24).

4. Use the Assets pane to add or replace asset files (for example, .epub or .ibooks, sample, cover art, or
screenshot files). For more information, see “Providing Asset Details” (page 36).

Continue using the Book and Assets panes to edit the package. For more information, see “Describing Your
Book Package” (page 24).

Creating Your Book Package
Opening an Existing Package
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Note: If you previously delivered the book package to the iBookstore, you can update all information, except
the book type and ISBN number, in the Book and Assets panes.

When you are sure the publication details are complete and correct, you can send your book package to iTunes
for processing. For more information, see “Delivering Your Book Package” (page 41).

Creating a Book Package from a File
You can create your book package by importing publication details from an iTunes Producer file, editing
publication details, and updating the information you want to submit to the iBookstore.

When creating a book package from a file, be sure to use the iTunes Producer template. To get a copy of the
template, choose File > Open Book File Import Template in iTunes Producer 2.9. iTunes Producer creates the
BookFileImportTemplates folder containing the BookFileImportTemplate.txt template. To always have an
original version of the template file, be sure to make a copy of the template before editing.

To create your book package by importing publication details from a file:

1. Click Create New Package in the “Choose an Activity” window.

The “Choose an Activity” window appears automatically when you open iTunes Producer 2.9 for books,
or you can choose File > New to display the “Choose an Activity” window from within iTunes Producer 2.9
(iTP) for books.

2. Select “New from file”, and then click Next.

iTP displays an Open dialog so you can select the file containing the publication details you want to import
into your book package.

3. Select the filename containing the publication details you want to include in your book package, and then
click Open.

iTP imports the publication details from the iTunes Producer file and displays the Book pane.

Notes:

 ● Any fields iTP cannot import are left blank, including misspelled field names or fields not acceptable
for import.

 ● If there is more than one ISBN in the file, iTP imports the publication details and displays an iTP window,
with the Book pane selected, for each unique ISBN.

4. Use the Book pane to add and edit publication information (for example, title and subtitle), categories,
authors, target audience, related products, and rights and pricing. For more information, see “Providing
Book Details” (page 24).

Creating Your Book Package
Creating a Book Package from a File
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5. Use the Assets pane to add or replace asset files (for example, .epub or .ibooks, sample, cover art, or
screenshot files). For more information, see “Providing Asset Details” (page 36).

Continue using the Book and Assets panes to edit the package. For more information, see “Describing Your
Book Package” (page 24).

When you are sure the publication details are complete and correct, you can send your book package to iTunes
for processing. For more information, see “Delivering Your Book Package” (page 41).

You can import the following fields into your book package (required fields in bold):

ExampleDescriptionName

BookIndicates the type of publication you want to send as an
iTunes Store Package (iTP package) to the iBookstore.

Book Type

9781101170373A unique, industry standard, and permanent number to
identify the record for this book. The ISBN number identifies
the electronic book, not the printed publication, and cannot
include dashes (-) or spaces.

ISBN

engA language to indicate the language in which the publication
was written, for this edition.

Language

Behind the
Looking Glass

The full title, without the subtitle, of the publication.Title

For Japanese, the reading (furigana) of the title in full-width
Hiragana or Katakana. For Chinese, Phonetic Title supports
Pinyin. This phonetic information provides a better search
experience for your users.

Notes:

 ● This field is for Japanese and Chinese phonetic titles
only.

 ● For Japanese, use a space character to indicate any
meaningful separation units.

 ● iTP strictly enforces a 255-byte limit, stored in the UTF-8
encoding. For single-byte characters (such as those
drawn from the ASCII character set), this equates to a
255-character limit; for multiple-byte characters (such
as Japanese), this can equate to as few as 71 characters.

Phonetic Title

Creating Your Book Package
Creating a Book Package from a File
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ExampleDescriptionName

Or, where the
rabbit went

The full subtitle of the publication.Subtitle

For Japanese, the reading (furigana) of the subtitle in
full-width Hiragana or Katakana. For Chinese, Phonetic
Subtitle supports Pinyin. This phonetic information provides
a better search experience for your users.

Notes:

 ● This field is for Japanese and Chinese phonetic titles
only.

 ● For Japanese, use a space character to indicate any
meaningful separation units.

 ● iTP strictly enforces a 255-byte limit, stored in the UTF-8
encoding. For single-byte characters (such as those
drawn from the ASCII character set), this equates to a
255-character limit; for multiple-byte characters (such
as Japanese), this can equate to as few as 71 characters.

Phonetic
Subtitle

Apple Publishing
Group

The name of the publisher that released the publication.Publisher

Macintosh
Publishing

The brand name the publisher uses on the title page of the
publication.

Imprint

Nov 12, 2009The date (YYYY-MM-DD) of the original, physical publication.
This is the date users see in the iBookstore. In most cases,
users want to see a list of books by a particular author sorted
in chronological order — the order in which the books were
written. If there is no physical edition equivalent, use the
publication date of the EPUB format or Multi-Touch format
file.

Publication
Date

Wonderland
Adventures

The series name, if the publication was published as part of
a series.

Series Name

Creating Your Book Package
Creating a Book Package from a File
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ExampleDescriptionName

For Japanese, the reading (furigana) of the series name in
full-width Hiragana or Katakana. For Chinese, Phonetic Series
Name supports Pinyin. This phonetic information provides
a better search experience for your users.

Notes:

 ● This field is for Japanese and Chinese phonetic titles
only.

 ● For Japanese, use a space character to indicate any
meaningful separation units.

 ● iTP strictly enforces a 255-byte limit, stored in the UTF-8
encoding. For single-byte characters (such as those
drawn from the ASCII character set), this equates to a
255-character limit; for multiple-byte characters (such
as Japanese), this can equate to as few as 71 characters.

Phonetic Series
Name

1The series number for the publication, if the publication was
published as part of a series.

Number In
Series

200The total number of pages in the physical publication, or
the closest equivalent.

Print Length

JUV007000The main subject that describes the general content of the
publication.

BISAC Main
Subject or BIC2
Main Subject or
CLIL Main
Subject

JUV001000A second subject that describes the content of the
publication. In addition to the main subject, you can add a
second and third subject.

BISAC Subject2
or BIC2 Subject2
or CLIL Subject2

JUV001010A third subject that describes the content of the publication.
In addition to the main subject, you can add a second and
third subject.

BISAC Subject3
or BIC2 Subject3
or CLIL Subject3

Creating Your Book Package
Creating a Book Package from a File
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ExampleDescriptionName

The sequel to
Alice's Adventures
in Wonderland.
Although it makes
no reference to
events in the
earlier book, the
themes and
settings of Behind
the Looking Glass
make it a mirror
image: the first
book begins
outdoors, in the
warm month of
May, uses
frequent changes
in size as a plot
device, and draws
on the imagery of
playing cards; the
second opens
indoors on a
snowy, wintry
night exactly six
months later, on
November 4 (the
day before Guy
Fawkes Night),
uses frequent
changes in time
and spatial
directions as a
plot device, and
draws on the
imagery of chess.
In it, there are
mirror themes,
including
opposites and
time running
backwards.

A detailed description for the publication. For example, the
description on the flap of a dust jacket or on the back cover.

The description can be up to 4000 bytes, can include Rich
Text, and must be suitable for public display. 4000 bytes is
approximately 2000 characters, depending on the language.
The book description requires a minimum of 50 characters.

Book
Description

Creating Your Book Package
Creating a Book Package from a File
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ExampleDescriptionName

TRUEIndicates whether or not the book is available as a sample
during pre-order. By default, iTP allows pre-orders. Pre-order
Samples Allowed only affects availability during the
pre-order period, and applies to every territory. When the
pre-order ends and the book is released for sale, samples
are always available.

Pre-order
Samples
Allowed

Lewis CarrollThe name of the person or corporation who contributed to
the creation of the publication, in normal order.

Author Name

The contributor name in full-width Hiragana or Katakana
for Japanese or in Pinyin for Chinese.

Author Phonetic
Name

trueIndicates that the author is a primary role author. You must
specify at least one primary role author.

PrimaryAuthor

By (author)The role the author played in the creation of the publication.Author Role

Carroll, LewisThe name of the person or corporation who contributed to
the creation of the publication, in inverted order, with a
comma between the last and first names for alphabetical
sorting in the Store and in the user's bookshelf.

Author Sort
Name

9780312355296An identifier for related print or digital products. Identifiers
can be ISBN-10 or ISBN-13. You can add a related product
by identifier without specifying additional information. Each
identifier can only occur once. If you provide only one
identifier, Apple recommends using the ISBN-13 number.
Apple recommends using identifiers that are different
versions of the publication, instead of using identifiers of
similar publications.

Related Product
Identifier

ISBN-13A type for the related product identifier.Related Product
Identifier Type

Print EquivalentA relationship to indicate how the product is related to the
publication.

Related Product
Relation

USA territory or country where you have rights to sell the book.Territory

Creating Your Book Package
Creating a Book Package from a File
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ExampleDescriptionName

New ReleaseA publication type for the book. You can specify New
Release, Digital Only, or Other. New Release books, defined
in your contract, are tied to specific discounts. Digital Only
books have no print equivalent or are significantly enhanced
(for example, multimedia titles) from the print edition. Other
refers to books that do not fall into the New Release or
Digital Only options (for example, backlist titles with a print
equivalent).

Publication
Type

Mar 12, 2010The date (YYYY-MM-DD), also known as a laydown date, on
which the book will be available for sale in the selected
territory. Books won't be shown in the store until the
specified Sales Start Date. By default, iTP makes the book
available for sale in the selected territory on the date you
created the book.

Sales Start Date

Mar 1, 2010The date (YYYY-MM-DD) on which the book will be available
for pre-order in the selected territory. Books won't be shown
in the store until the specified date. The Pre-Order Start Date
must be earlier than the Sales Start Date. If you do not want
to offer your book as a pre-order, leave Pre-Order Start Date
blank.

Pre-Order Start
Date

TRUEIndicates whether or not the book should be made available
for sale in the selected territory. By default, iTP clears the
book for sale.

Cleared For Sale

TRUEIndicates whether or not the book can be sold in Digital
Rights Management (DRM) free format in the selected
territory.

DRM Free

14A price tier for the book.Price Tier

USDIndicates the currency used for the selected territory where
you will sell the book.

Currency

Creating Your Book Package
Creating a Book Package from a File
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ExampleDescriptionName

25.99The publisher’s suggested retail price of the hardcover
edition of the publication in the selected territory. If the
publication was never available in hardcover, use the
suggested retail price of the paperback. If the book was only
available in digital format, use the suggested retail price of
what a physical edition would have been using your
established pricing practices. Specify the Physical List Price
in the currency and format for the selected territory (for
example, ##.## for USD or ##,## for Euros).

Physical List
Price

GeneralSpecifies the Apple audience for your publication. Audience
Apple is intended to provide a simple, high-level way for
you to indicate the general target audience for your
publication.

Audience Apple

Third GradeSpecifies the U.S. School Grade audience for your
publication. Use U.S. School Grade to target a publication
at a specific grade range in the U.S. school system.

Audience U.S.
School Grade

Second GradeSpecifies the Canadian School Grade audience for your
publication. Use Canadian School Grade to target a
publication at a specific grade range in the Canadian school
system.

Audience
Canadian
School Grade

MaternelleSpecifies the Quebec School Grade audience for your
publication. Use Quebec School Grade to target a publication
at a specific grade range in the Quebec school system.

Audience
Quebec School
Grade

Year 1Specifies the Australian School Grade audience for your
publication. Use Australian School Grade to target a
publication at a specific grade range in the Australian school
system.

Audience
Australian
School Grade

Key Stage 1Specifies the U.K. National Curriculum audience for your
publication. Use U.K. National Curriculum to target a
publication at a specific grade range in the U.K. school
system.

Audience U.K.
National
Curriculum

Scottish
Qualifications
Authority

Specifies a single target audience.Audience U.K.
Exam Board

1st Level (P2-P4)Specifies the Scotland Curriculum audience for your
publication. Use Scotland Curriculum to target a publication
at a specific grade range in the Scotland school system.

Audience
Scotland
Curriculum

Creating Your Book Package
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ExampleDescriptionName

6Specifies the minimum age for the Audience Interest Age
for your publication. Use Audience Interest Age (In Years)
to target a publication by the age group for which the
material is likely to be interesting.

Audience
Interest Age (In
Years) Min

8Specifies the maximum age for the Audience Interest Age
for your publication. Use Audience Interest Age (In Years)
to target a publication by the age group for which the
material is likely to be interesting.

Audience
Interest Age (In
Years) Max

Notes:

 ● You can exclude any column, as long as you leave the column heading intact.

 ● To avoid import warnings and errors, be sure descriptions are no more than 4000 bytes, in Rich Text
formatting, and suitable for public display. Note that 4000 bytes is approximately 2000 characters, depending
on the language. The book description requires a minimum of 50 characters.

 ● Only include fields for the data you want to import. iTP imports empty or blank fields as blank data and
overwrites any existing data.

 ● All rows of data must be contiguous. To import data successfully, there can be no blank rows of data
between any two rows of data.

Looking Up Metadata for an Existing Book
You can create your book package by looking up the metadata from an existing iBookstore book you previously
delivered, editing publication details, and updating the assets you want to submit to the iBookstore.

Create your book package using metadata from an existing book when you want to update your metadata or
assets, and resend it to iTunes, even when you no longer have the original book. This feature is especially
helpful for redelivering your assets, because you can recreate and resend the original book package with only
the new assets included.

To create your book package by looking up metadata from an existing book:

1. Click Look Up Metadata in the “Choose an Activity” window.

The “Choose an Activity” window appears automatically when you open iTunes Producer 2.9 for books,
or you can choose File > New to display the “Choose an Activity” window from within iTunes Producer 2.9
(iTP) for books.

Creating Your Book Package
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2. Type one or more ISBN, Apple ID, or Vendor IDs, using a comma-separated list, for the books containing
the content you want in the AppleID/VendorID field.

3. Click Look Up.

iTP authenticates the ISBN, searches for the associated metadata, and then displays an iTP window for
each unique ISBN.

Click Abort to stop metadata lookup.

4. Use the Book pane to add and edit publication information (for example, title and subtitle), categories,
authors, target audience, related products, and rights and pricing. For more information, see “Providing
Book Details” (page 24).

5. Use the Assets pane to add or replace asset files (for example, .epub or .ibooks, sample, cover art, or
screenshot files). For more information, see “Providing Asset Details” (page 36).

Continue using the Book and Assets panes to edit metadata. For more information, see “Describing Your Book
Package” (page 24).

Note: If you previously delivered the book package to the iBookstore, you cannot update all information in
the Book and Assets panes. For more information, see “What elements can I update in my book?” (page 44).

When you are sure the publication details are complete and correct, you can send your book package to iTunes
for processing. For more information, see “Delivering Your Book Package” (page 41).

Creating Your Book Package
Looking Up Metadata for an Existing Book

2013-02-20   |   © 2013 Apple Inc. All Rights Reserved.

23



After you create your initial book package, but before your publication content is ready to be sent for sale in
the iBookstore, you must prepare your book package by describing the publication in detail, including title,
subtitle, publisher, categories, authors, target audience, related products, rights and pricing, assets, and more.

Providing Book Details
Before sending your book package to the iBookstore, use the Book pane of iTunes Producer 2.9 (iTP) for books
to provide publication information, categories, authors, target audience, related products, and rights and
pricing details.
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Entering Book Information
Use the Book > Info pane to provide as much detail as possible about your publication. The information you
provide represents all the book-level metadata.

To provide book information details:

1. Click Info at the bottom of the Book pane.

Note: iTP automatically generates the Vendor ID. iTP creates an iTunes Store Package (iTP package) for
your book using the Vendor ID and a .itmsp extension. To manually edit the Vendor ID, choose iTunes
Producer > Preferences, click Publication, and then choose “Editable before delivery”.

2. Enter book information:

ISBN: Type a unique, industry standard, and permanent number to identify the record for this book. The
ISBN number identifies the electronic book, not the printed publication, and cannot include dashes (-) or
spaces. Apple recommends using the 13-digit ISBN number. Although optional for delivering your book
to the iBookstore, ISBN numbers are often required for reporting your book's sales back to the industry
reporting agencies and for charting on national charts.

Describing Your Book Package
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Book Type: Choose Book or Textbook to indicate the type of publication you want to send as an iTunes
Store Package (iTP package) to the iBookstore. By default, iTP specifies a book. If you choose Textbook,
the publication asset you add to the Publication or Publication Sample box must be in Multi-Touch format.
You can send publications of type Textbook only if this type is defined in the terms of your contract.
Currently, textbooks are only available in the U.S. market.

Language: Choose a language to indicate the language in which the publication was written, for this
edition. If you choose Japanese, in addition to the Title and Subtitle you can specify the Phonetic Title,
Phonetic Subtitle, and Phonetic Series Name.

Title: Type the full title, without the subtitle, of the publication.

Subtitle: Type the full subtitle of the publication.

Publisher: Type the name of the publisher that released the publication.

Imprint: Type the brand name the publisher uses on the title page of the publication. For example, type
Puffin Books (imprint for the publisher Penguin Group).

Publication Date: Type the date (YYYY-MM-DD) of the original, physical publication. This is the date users
see in the iBookstore. In most cases, users want to see a list of books by a particular author sorted in
chronological order — the order in which the books were written. If there is no physical edition equivalent,
use the publication date of the EPUB format or Multi-Touch format file. You can specify values such as
“today”, “yesterday”, and “last month”, and iTP correctly formats the date.

Series Name: Type the series name, if the publication was published as part of a series. For example, Isaac
Asimov's. If you do not specify a name in Series Name, you cannot specify a value for “Number in Series”.

Number in Series: Type the series number for the publication, if the publication was published as part of
a series. Enter a numeric value only. For example, 3 (not Book 3 or Book Three). If you specify a value for
“Number in Series”, you must specify a name in Series Name.

Store Display Number: Type the series number you want to appear in the iBookstore. For example, “Book
3” or “Volume III”. You can use Store Display Number to override the display number in the iBookstore.
For example, if you have three books labeled Series A, Series B, and Series Z you can use Store Display
Number to change the display number for Series Z to Series C. If you specify a value for Series Name, you
must specify a series number in Store Display Number.

Print Length: Type the total number of pages in the physical publication, or the closest equivalent.

Pre-order samples allowed: Select whether or not the book should be available as a sample during the
pre-order period. By default, iTP allows pre-order samples. “Pre-order samples allowed” only affects
availability during the pre-order period, and applies to every territory. When the pre-order ends and the
book is released for sale, samples are always available.
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Explicit Content Select whether or not the book contains sexually explicit content. If you mark a book as
explicit, users with parental control preferences enabled cannot download the book. Additionally, users
cannot view the book’s cover art or read the book’s description. To change the Explicit Content setting
after you submit your book package to the iBookstore, contact the iBookstore support.

Multi-touch expected: Select whether or not the book is in Multi-Touch format. Multi-Touch books are
designed to be displayed on an iPad, not on an iPhone or iPod touch. Use the “Multi-touch expected”
checkbox to specify that a book is in Multi-Touch format and protect iPhone and iPod touch users from
pre-ordering books they cannot read on their devices. This option is only available if you are approved for
pre-orders without assets and the iTP package does not already contain a publication asset.

3. Type a detailed description for the publication in Book Description. For example, the description that
appears on the flap of a dust jacket or on the back cover of a publication. The description can be up to
4000 bytes, can include Rich Text formatting, and must be suitable for public display. Note that 4000 bytes
is approximately 2000 characters, depending on the language. The book description requires a minimum
of 50 characters.

4. Click Next or Categories at the bottom of the Book pane. For more information, see “Entering Book
Categories” (page 28).

The ISBN identifiers are usually printed above the barcode of publications. After you provide an ISBN value
and save your book package, iTP creates an iTunes Store Package (iTP package) for your book using the ISBN
value and a .itmsp extension.
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Entering Book Categories
Use the Book > Categories pane to add and define categories for your publication. The information you provide
represents all the book-level metadata.

To provide book category details:

1. Click Categories at the bottom of the Book pane.

2. Click Add Category to add a new category for your publication.

To remove a previously added category, select the category and then click Remove Category.

Use the search field to filter categories in the table by Category Scheme and Categories.

3. Choose BISAC, BIC2, or CLIL from the Category Scheme pop-up menu.

For more information, click to display the Book Industry Study Group website (http://www.bisg.org/what-
we-do-0-136-bisac-subject-headings-list-major-subjects.php), the Book Industry Communication website
(http://www.bic.org.uk/), or the Commission de Liaison Interprofessionnelle du Livre website
(http://clil.org/information/detailDoc.html?docId=6), depending on the subject category scheme selected
in the pop-up menu.

4. Choose the main subject that describes the general content of the publication from the Category pop-up
menu, and then choose a subheading to provide a specific subject category from the second pop-up
menu.
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5. Click Primary to indicate that the subject category is a primary category. You must specify at least one
category as primary for each category scheme (BISAC, BIC2, or CLIL). If you add more than one of the same
category, you must specify which category is primary.

6. Repeat steps 2 through 5 for each category you want to add to your publication.

To reorder categories, select a category and drag and drop to the desired position in the box.

7. Click Next or Authors at the bottom of the Book pane. For more information, see “Entering Book
Authors” (page 29).

Note: To set a default subject category, choose iTunes Producer > Preferences, click Publication, and then
choose BISAC, BIC2, or CLIL from the Default Subject Category Scheme pop-up menu.

Entering Book Authors
Use the Book > Authors pane to provide as much detail as possible about the authors of your publication. The
information you provide represents all the book-level metadata.

To provide book author details:

1. Click Authors at the bottom of the Book pane.

2. Click Add Author, and then choose the role the author played in the creation of the publication from the
Role pop-up menu. For example, “Illustrated by” or “Text by”.
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To remove a previously added author, select the author and then click Remove Author.

Use the search field to filter authors in the table by Role, Name, and Sort Name information.

3. Type the name of the person or corporation who authored the publication in Name, in normal order. For
example, Jules Verne or The Historical Society of Sonoma County. If you specified Japanese or Chinese
(Traditional or Simplified) as the language in the Book > Info pane, you can also type the Phonetic Name
of the person or corporation who authored the publication, in normal order.

4. Type the name of the person or corporation who authored the publication in “Sort name”, in inverted
order, with a comma between the last and first names for alphabetical sorting in the Store and in the user's
bookshelf. For example, Verne, Jules or Historical Society of Sonoma County, The.

5. Click Primary to indicate that the author is a primary role author.

You must specify at least one primary role author.

6. Repeat steps 2 through 5 for each author you want to add to your publication.

If an author has more than one role, add a separate entry for each role.

To reorder authors, select the author and drag and drop to the desired position in the box.

7. Click Next or Target Audience at the bottom of the Book pane. For more information, see “Entering Book
Target Audience” (page 30).

Entering Book Target Audience
Use the Book > Target Audience pane to indicate the intended audience for your publication. If your publication
applies to more than one target audience, you can specify multiple audiences. The information you provide
represents all the book-level metadata.

Because there are a number of different dimensions by which you might differentiate target audiences (for
example, by overall market segment, age, school grade, reading level, etc.), iTunes Producer 2.9 (iTP) for books
supports various criteria for specifying a target audience. Depending on the criteria, you can specify a single
value, a range of values with a minimum and maximum, or open ranges (for example, “6 and up” and “up to
6”). Ranges are inclusive on both ends. The only valid target audience values (interest age) are:

0-2

3-5

6-8

9-12

13 and Up

To provide book target audience details:

Describing Your Book Package
Providing Book Details

2013-02-20   |   © 2013 Apple Inc. All Rights Reserved.

30



1. Click Target Audience at the bottom of the Book pane.

2. Click Add Criteria to add a new target audience criteria for your publication, and then choose Apple, U.S.
School Grade, Canadian School Grade, Quebec School Grade, Australian School Grade, U.K. National
Curriculum, U.K. Exam Board, Scotland Curriculum, or Interest Age (In Years) from the Target Audience
Criteria pop-up menu.

To remove a previously added criteria, select the criteria and then click Remove Criteria.

Use the search field to filter target audiences in the table by Target Audience Criteria or Target Audience
information.

3. Do one of the following:

 ● For Apple, choose a single target audience. For example, Children. The Apple criteria is intended to
provide a simple, high-level way for you to indicate the general target audience for your publication.

 ● For U.S. School Grade, Canadian School Grade, Quebec School Grade, Australian School Grade, U.K.
National Curriculum, or Scotland Curriculum, click Single Grade or Grade Range and then choose a
grade level from the pop-up menus to define your target audience. For Grade Range, you can select
either a minimum grade level, a maximum grade level, or both. Use the school grade criteria to target
a publication at a specific grade range in the specified school system.

 ● For U.K. Exam Board, choose a single target audience. For example, Scottish Qualifications Authority.

 ● For Interest Age (In Years), choose an age range from the pop-up menu to define your target audience
range. Use the Interest Age (In Years) criteria to target a publication by the age group for which the
material is likely to be interesting.
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4. Repeat steps 2 through 3 for each target audience you want to add to your publication.

You can add each target audience criteria only once.

5. Click Next or Related Products at the bottom of the Book pane. For more information, see “Entering Book
Related Products” (page 32).

Entering Book Related Products
Use the Book > Related Products pane to provide as much detail as possible about your publication’s related
products. The information you provide represents all the book-level metadata.

To provide book related product details:

1. Click Related Products at the bottom of the Book pane.

2. Click Add Related Product, and then choose a relationship to indicate how the product is related to the
publication from the Relation pop-up menu. For example, “Is part of” or “Is special edition of”. Related
products can be the same product in an alternative format. For example, a 2010 travel guide that replaces
a 2009 travel guide.

To remove a previously added related product, select the related product and then click Remove Related
Product.

Use the search field to filter related products in the table by Relation and Identifiers information.
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3. Type an ISBN-13 identifier for the related products in the ISBN-13 field.

You can add a related product by identifier without specifying additional information. Each identifier can
only occur once. If you provide only one identifier, Apple recommends using the ISBN-13 number. Apple
recommends using identifiers that are different versions of the publication, instead of using identifiers of
similar publications.

To remove a previously added identifier, select the identifier in the ISBN-13 field and press the Delete key.

4. Type an ISBN-10 identifier for the related products in the ISBN-10 field.

You can add a related product by identifier without specifying additional information. Each identifier can
only occur once. If you provide only one identifier, Apple recommends using the ISBN-13 number. Apple
recommends using identifiers that are different versions of the publication, instead of using identifiers of
similar publications.

To remove a previously added identifier, select the identifier in the ISBN-10 field and press the Delete key.

5. Repeat steps 2 through 4 for each related product you want to add to your publication.

To reorder related products, select the related product and drag and drop to the desired position in the
box.

6. Click Next or Rights & Pricing at the bottom of the Book pane. For more information, see “Entering Book
Rights and Pricing” (page 34).
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Entering Book Rights and Pricing
Use the Book > Rights & Pricing pane to provide as much detail as possible about the rights and pricing for
your publication. The information you provide represents all the book-level metadata.

To provide book rights and pricing details:

1. Click Rights & Pricing at the bottom of the Book pane.

2. Click Add Territory to change availability.

If you don't see a region that includes only the countries where the book can be sold, create a territory
line entry for each country where the book can be sold.

Click Mass Territory Set Up to add several territories with rights and pricing at once. You can specify the
DRM free status, Sales Start Date, Base Currency, Publication Type, List Price, and Suggested iBookstore
Price for an entire set of territories all at once.

To remove a previously added territory, select the territory and then click Remove Territory.

Use the search field to filter territories in the table by Code, Territory, Start, and Tier information.

3. Choose a region where you have rights to sell the book from the Territory pop-up menu.

Click Make Default to specify that you want iTP to use all the designated rights and pricing as the default
rights and pricing for all future books.

4. Enter rights and pricing information for the book:
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Publication Type: Choose a type for the publication in the selected territory. You can choose New Release,
Digital Only, or Other. New Release publications, defined in your contract, are tied to specific discounts.
Digital Only publications have no print equivalent or are significantly enhanced (for example, multimedia
titles) from the print edition. Other refers to publications that do not fall into the New Release or Digital
Only options (for example, backlist titles with a print equivalent).

Sales Start Date: Type the date (YYYY-MM-DD), also known as a laydown date, on which the publication
will be available for sale in the selected territory. Publications won't be shown in the store until the specified
Sales Start Date. By default, iTP makes the publication available for sale in the selected territory on the
date you created the book as an iTunes Store Package (iTP package).

Pre-Order Start Date: Type the date (YYYY-MM-DD) on which the publication will be available for pre-order
in the selected territory. Publications won't be shown in the store until the specified Pre-Order Start Date.
The Pre-Order Start Date must be earlier than the Sales Start Date. By default, iTP sets the Pre-Order Start
Date to the date when you clicked Add Territory. If you do not want to offer your book as a pre-order,
leave the Pre-Order Start Date field blank.

Physical List Price: Type the publisher’s suggested retail price of the hardcover edition of the publication
in the selected territory. If the publication was never available in hardcover, use the suggested retail price
of the paperback. If the publication was only available in digital format, use the suggested retail price of
what a physical edition would have been using your established pricing practices. Specify the Physical List
Price in the currency and format for the selected territory (for example, ##.## for USD or ##,## for Euros).

Price Tier: Choose a price tier for the publication.

For more information, click to display a pop-up dialog containing the available price tier names, your
proceeds, and tier codes for the selected territory. To select a price tier, click the tier name, and then click
Done.

Cleared for sale: Select whether or not the publication should be made available for sale in the selected
territory. By default, iTP clears the publication for sale. Deselecting “Cleared for sale” removes the publication
from the iBookstore.

DRM free: Select whether or not the publication can be sold in Digital Rights Management (DRM) free
format in the selected territory.

5. Repeat steps 2 through 4 for each territory where you have rights to sell the publication.

6. Click Next.

iTunes Producer 2.9 (iTP) for books displays the Assets pane so you can add or replace asset files (for
example, .epub or .ibooks, sample, cover art, or screenshot files). For more information, see “Providing
Asset Details” (page 36).
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Providing Asset Details
Before sending your book package to the iBookstore, use the Assets pane of iTunes Producer 2.9 (iTP) for books
to add or replace asset files (for example, .epub or .ibooks, sample, cover art, or screenshot files).

Depending on your provider settings, assets are required when sending the initial version of your book package
to the iBookstore.

Specifying Publication Assets
Use the Assets > Publication pane to specify the publication assets (for example, .epub or .ibooks and sample)
for your book. The information you provide represents all the book-level metadata.

To specify publication assets:

1. Click Publication at the bottom of the the Assets pane.

2. Drag the publication’s EPUB format (.epub) or Multi-Touch format (.ibooks) file to the Publication box, or
click Choose and select a file in EPUB or Multi-Touch format. For books, the file must be in EPUB or
Multi-Touch format. For textbooks, the file must be in Multi-Touch format.
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To replace a previously added file, drag a new file to the Publication box or click Choose to select a new
file, or choose Edit > Delete to delete the file and then add a new file.

3. Drag an EPUB sample (.epub) or Multi-Touch format sample (.ibooks) file for the publication to the
Publication Sample box, or click Choose and select a sample file in EPUB or Multi-Touch format. You must
submit a sample file for all Read Aloud EPUB files and all publications in Multi-Touch format. The sample
file format must match your publication file format. If your publication contains pictures or other non-text
media, you might want to create a custom sample file to ensure the sample includes everything you want.
iTP warns you if your sample file is the same as, or larger than, your full publication file.

For EPUB format, if you do not add an EPUB sample file, the iBookstore automatically creates a sample.
What the sample contains depends on the type of book (for example, the first chapter of your publication,
5% of the total word count, a percentage of the total page count, and so on). If you do not want the
iBookstore to cut the sample automatically, you can create a separate, custom .epub file and deliver it for
use as the sample in the iBookstore.

For Multi-Touch books, if you do not add a Multi-Touch sample file, the iBookstore does not automatically
create a sample. You can continue to deliver your publication, but you cannot sell your Multi-Touch format
publication until you add a sample file.

To replace a previously added file, drag a new file to the Publication Sample box or click Choose to select
a new file, or choose Edit > Delete to delete the file and then add a new file.

4. Click Next or Cover Art at the bottom of the Assets pane. For more information, see “Specifying Cover Art
Assets” (page 38).

To validate and repair an EPUB file or sample file before delivering your book package for processing, select
the file in the Publication box or Publication Sample box and then choose File > Repair EPUB. iTP attempts to
repair the file and:

 ● If the repair is successful, iTP replaces the original file in the iTunes Store Package (iTP package) with the
repaired file for delivery.

 ● If the repair fails, iTP displays an error message indicating the repair was unsuccessful.

If you do not repair an invalid EPUB file or sample file before delivery, iTP reports the error in the Delivery pane
and displays the Repair button in the Assets > Publication pane. Click the Repair button to validate and repair
the EPUB file or sample file. You cannot deliver your book package for processing with an invalid EPUB file.

Note: Apple recommends delivering files less than 200 MB as users can run into trouble downloading files
greater than 200 MB, 2 GB is the file limit. In addition, in many markets, 20 MB is the file limit for cellular
networks.
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Specifying Cover Art Assets
Use the Assets > Cover Art pane to specify the cover art asset for your publication. The information you provide
represents all the book-level metadata.

To specify cover art assets:

1. Click Cover Art at the bottom of the the Assets pane.

2. Drag the publication’s cover art to the Cover Art box, or click Choose and select a cover art file.

Cover art (also known as a marketing image or jacket) should be at least 1400 pixels along the smaller axis
and must be a JPEG or PNG file in RGB Color mode. For an average trade paperback, this could be 1400 x
1873 minimum size, as the books are generally taller than they are wide. For best results, deliver the largest
pixel dimensions possible. When possible, match cover art to the cover contained in the book file. The 2
million pixel maximum does not apply to the cover image.

Do not scale up artwork if it is smaller than the required size. If you are scanning your cover art be sure to
scan at the highest resolution, or at least 1400 pixels along the smaller axis. Cover art must be at least 72
dots per inch (dpi). Do not submit art that contains an embedded color profile, back cover, or thumbnail
art.

To replace a previously added file, drag a new file to the Cover Art box or click Choose to select a new file,
or choose Edit > Delete to delete the file and then add a new file.
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3. Click Next or Screenshots at the bottom of the Assets pane. For more information, see “Specifying Screenshot
Assets” (page 39).

Specifying Screenshot Assets
Use the Assets > Screenshots pane to specify the screenshot assets for your publication and show your customers
more about your visually-oriented publications (for example, fixed layout, read along, interactive, or Multi-Touch
format). The information you provide represents all the book-level metadata.

To specify screenshot assets:

1. Click Screenshots at the bottom of the the Assets pane.

2. Click Add Screenshot to add a new screenshot asset for your publication.

To remove a previously added screenshot, select the screenshot and then click Remove Screenshot.

3. Drag one or more screenshots to the Upload Screenshot box, or click Choose and select a screenshot file.

Screenshots should be a clear picture, made on an iPad, and be a 1024 x 768, 1024 x 748, 768 x 1024, or
768 x 1004 pixel JPEG or PNG file (for an iPad 1 or 2, double for the new iPad) with the appropriate file
extensions (.jpg, .jpeg, and .png) in RGB Color mode. Optionally, you can remove the status bar.

To replace previously added files, drag new files to the Upload Screenshot box or click Choose to select a
new file, or choose Edit > Delete to delete the file and then add a new file.

4. Repeat steps 2 through 3 for all screenshots you want to add to your publication.

Describing Your Book Package
Providing Asset Details
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You can add up to five screenshots for your publication.

To reorder screenshots, select the screenshot and drag and drop to the desired position in the box or click
the up and down arrows to reorder screenshots.

5. Click Next at the bottom of the Assets pane. For more information, see “Delivering Your Book Package” (page
41).

Describing Your Book Package
Providing Asset Details
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The final step in preparing content for sale in the iBookstore is to deliver your book package to iTunes for
processing. Once you have created your book package and specified all your publication details, you can deliver
your book and all your prepared files as an iTunes Store Package (iTP package) directly to Apple’s iBookstore.
This section describes how to send your iTP package to iTunes for processing and how to send Apple a log
report if you encounter errors during delivery.

Sending a Package to the iBookstore
When you are sure publication details are complete and correct, including all asset files, you can send your
book and all your prepared files as an iTunes Store Package (iTP package) to iTunes for processing.

To deliver a package:

1. Click the Delivery pane for your book in the iTunes Producer 2.9 (iTP) for books window.

iTP processes all the publication details and displays any warnings or errors.

2013-02-20   |   © 2013 Apple Inc. All Rights Reserved.

41

Delivering Your Book Package



2. Fix any delivery warnings or errors.

Double-click on a warning or error to have iTP jump to the exact location of the problem. For more
information about errors, see the Contact Us page in iTunes Connect at http://www.ap-
ple.com/itunes/go/itunesconnect/contactus.

Click Activity to display the Background Activity window and view delivery status information for all
packages you are currently sending, including pending messages, time remaining, warning and error
messages, and so on.

3. Click Deliver.

iTP packages all your publication details and prepared files into an iTP package and sends it to the
iBookstore.

You can also choose File > “Save and Deliver” to save and package all your publication details and prepared
files into an iTP package and send it to the iBookstore. Or, to send multiple packages at once, choose File
> “Save and Deliver All”. iTP saves and packages all your publication details and prepared files, for all open
iTP windows, into iTP packages and sends them to the iBookstore.

For more information about delivery errors and answers to common questions, click Error Information to
display the iTunes Connect - Frequently Asked Questions page.

Notes:

 ● Until Apple has imported all your metadata, you can continue to update books and resend packages. After
Apple imports all your metadata, you can still update your rights & pricing, cover art, and EPUB information
by editing and resending your package to the iBookstore.

 ● For information on how to create a file in EPUB format, see “How do I create a file in EPUB format?” (page
47).

 ● For information on how to create a file in Multi-Touch format, see “How do I create a file in Multi-Touch
format?” (page 47).

 ● If you do not repair an invalid EPUB file or sample file before delivery, iTP reports the error in the Delivery
pane and displays the Repair button in the Assets > Publication pane. Click the Repair button to validate
and repair the EPUB file or sample file. You cannot deliver your book to iTunes for processing with an
invalid EPUB file.

 ● iTP plays an alert sound and displays a green checkmark when the package delivery is complete. If iTP
encounters an error during delivery, iTP plays an error sound and bounces the iTP icon in the Dock.

 ● To modify your delivery settings, choose iTunes Producer > Preferences, click Advanced, and then deselect
Signiant, Aspera, or DAV. You should only change these settings with the advice of your Technical Account
Manager. For questions, visit the Contact Us page in iTunes Connect at http://www.ap-
ple.com/itunes/go/itunesconnect/contactus.

Delivering Your Book Package
Sending a Package to the iBookstore
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Sending Your Log Report to Apple
If you encounter an error while delivering your book package to Apple, iTunes Producer 2.9 for books creates
a log report for you to send to Apple to help with troubleshooting your delivery issues.

Apple recommends you attempt to validate and repair an EPUB file before delivering your book package for
processing or submitting errors. If you do not repair an invalid EPUB file before delivery, iTP reports the error
in the Delivery pane and displays the Repair button in the Assets > Publication pane. Click the Repair button
to validate and repair the EPUB file. You cannot deliver your book package to iTunes for processing with an
invalid EPUB file.

To send the log report:

1. Click “Send to Apple” or in the Delivery pane.

2. Review the details of the error log and, optionally, add notes and comments before sending.

3. Click “Send to Apple” to deliver the error log to the iBookstore support team.

Delivering Your Book Package
Sending Your Log Report to Apple
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This section features some of the top tasks you might perform using iTunes Producer 2.9 for books.

Can I save a preliminary version of my book package before sending
it to the iBookstore?
If you’re not ready to send your book package to the iBookstore and want to finish later, you can save a
preliminary version.

To save your book package:

 ● Choose File > Save for your book in the iTunes Producer 2.9 (iTP) for books window.

Before you can save your book package, you must first specify an ISBN or publication title.

iTP saves your book and all your prepared files as an iTunes Store Package (iTP package) using the ISBN
or Vendor ID as the name and the .itmsp extension.

To reopen a saved book, open iTP, Click Open Package, and then double-click the book name.

By default, iTP saves books in the Music > iTunes Producer > Playlists folder.

Note: By default, iTP automatically saves your book as Untitled .itmsp, ISBN .itmsp, or title .itmsp every 15
seconds. To turn off autosaving or change the default autosave time, choose iTunes Producer > Preferences,
click General, and then deselect Autosave or change the seconds.

What elements can I update in my book?
You can update all publication details, except the ISBN number and book type, for a book you previously
delivered to the iBookstore.
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How do I remove a book from the iBookstore?
If you need to remove a book after you deliver it to the iBookstore, log in to iTunes Connect, click Manage Your
Content, and then search for the book. After inspecting the book, you can remove the book from sale by
clicking Edit in the far right column in the Rights & Pricing module and removing the clearances. Removing
clearances removes the book from all Stores in all countries. For more information, see iBookstore: Publisher
User Guide available for download from iTunes Connect.

To remove a book from the iBookstore, you can also deselect “Cleared for sale” in the Book > Rights & Pricing
pane for all countries and redeliver your book.

How do I deliver a book that is available for pre-order?
Pre-orders allow you to accrue sales in advance of publication, and can provide a great way to increase your
overall book sales.

1. Create your book in iTunes Producer 2.9 (iTP) for books. For information on creating a book, see “Creating
Your Book Package” (page 12).

2. Click the Book > Info pane for your book in the iTP window.

3. Select “Pre-order samples allowed”.

By default, iTP allows pre-order samples. “Pre-order samples allowed” only affects availability during the
pre-order period, and applies to every territory. When the pre-order ends and the book is released for sale,
samples are always available.

4. Click the Book > Rights & Pricing pane for your book.

5. Type the date (YYYY-MM-DD) on which the book will be available for pre-order in the selected territory
in Pre-Order Start Date.

A pre-order start date is required to create a pre-order. Pre-order start dates can vary by territory. To apply
the pre-order to all territories, Shift-click to select all territories, and then edit the value in Pre-Order Start
Date.

6. Click the Delivery pane.

iTP processes all the publication details and displays any warnings or errors.

7. Fix any delivery warnings or errors.

Double-click on a warning or error to have iTP jump to the exact location of the problem.

8. Click Deliver.

iTP packages all your publication details and prepared files into an iTP package and sends it to the
iBookstore.

Featured Tasks
How do I remove a book from the iBookstore?
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Important: Pre-orders require minimal manual production work by iTunes. When you deliver a book that is
available for pre-order, contact your iTunes Technical Account Manager. Pre-orders must conform to the
following specifications:

 ● All assets (EPUB, Multi-Touch format, cover art, and screenshot files) are due up front.

 ● You can only create pre-orders with the first, initial delivery of the book package.

 ● Each territory where you are sending a pre-order (each territory where you defined a pre-order start date)
must be priced at a valid price tier.

 ● Do not send pre-order start dates for territory products that have been marked not cleared for sale. Only
deliver book packages with pre-order start dates assigned for territory products that are cleared for sale.

Why is editing disabled for my book package?
After you deliver your book package to the iBookstore, iTunes Producer 2.9 for books disables editing for fields
you can no longer update.

To turn on editing:

 ● Choose File > Enable Editing for your book in the iTunes Producer 2.9 for books window.

Apple does not recommend enabling editing. If you enable editing and make updates to your book package,
you might not be able to deliver your book package to the iBookstore. Use the enable editing feature when
you are instructed to do so by your iTunes Technical Account Manager (for example, when you've delivered a
partial book).

Can I sort information within iTunes Producer windows?
Many panes in iTunes Producer 2.9 (iTP) for books display information in lists, allowing you to sort the information
by column heading. For example, in the Book > Authors pane, you can sort authors by role, name, or sort name.
To change the order in which iTP displays authors in the list and sort authors by name, click the Name column
heading. To reverse the sort order, click the column heading again.

iTP indicates the current sort order by highlighting the column and displaying in the column heading.

You can rearrange the order of the columns by dragging the column headers to the left or right. To adjust the
width of the columns, drag the separator lines between the column headers.

Featured Tasks
Why is editing disabled for my book package?
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How can I check the history and status of packages?
You can check the history and status of packages before and after you deliver them to the iBookstore.

To check the history before delivery:

 ● Choose File > Package History for your publication in the iTunes Producer 2.9 for books window, type your
ISBN/Vendor ID, and then click Search.

To check the status after delivery:

 ● Choose Window > Lookup Status in the iTunes Producer 2.9 for books window, type your ISBN/Vendor
ID, and then click Search.

iTunes Producer 2.9 for books displays the current state and date created for the package.

I don't see any activities in the “Choose an Activity” window. What
should I do?
If the “Choose an Activity” window does not display any activities, you do not have an active contract with
iTunes. You must complete the contract process before you can deliver content for sale in the iBookstore. For
more information, see the Contracts, Tax and Banking module in iTunes Connect.

How do I create a file in EPUB format?
You can use Pages to create a file in EPUB format. For more information, see the Knowledge Base article Creating
ePub files with Pages at http://support.apple.com/kb/HT4168.

You can also use an Apple-approved conversion house. For more information, see the Deliver Your Content
module in iTunes Connect.

How do I create a file in Multi-Touch format?
You can use iBooks Author (available in the Mac App Store at http://itunes.apple.com/us/app/ibooks-au-
thor/id490152466?ls=1&mt=12) to create a file in Multi-Touch format. For more information, see the Deliver
Your Content module in iTunes Connect.

Featured Tasks
How can I check the history and status of packages?
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How do I set a default category scheme?
You can use the preferences window to set a default category scheme for all new books.

Note: iTunes Producer 2.9 for books does not accept unclassified or non-specific subject categories.

To set a default category scheme:

1. Choose iTunes Producer > Preferences in the iTunes Producer 2.9 (iTP) for books window.

2. Click Publication.

3. Choose BISAC, BIC2, or CLIL from the Default Subject Category Scheme pop-up menu.

iTP uses the default you specify for all new books you create.

Do any languages require EPUB 3.0, iBooks 3.0 app, and iOS 6?
Yes. The following table is a list of the languages that require EPUB 3.0, iBooks 3.0 app, and iOS 6 to be supported
by iBookstore as the primary language.

Language

Arabic

Burmese

Chinese

Dari

Hebrew

Japanese

Khmer

Kurdish

Lao

Malay

Pashto

Persian

Featured Tasks
How do I set a default category scheme?
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Language

Punjabi

Sindhi

Tajik

Urdu

Uyghur

Uzbek

Featured Tasks
Do any languages require EPUB 3.0, iBooks 3.0 app, and iOS 6?
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The glossary defines terms you’ll encounter as you
read this guide.

authors  A group of elements that describes a
personal or corporate contributor to the publication
you are sending in the book package to the
iBookstore.

BISAC  The Book Industry Standards and
Communications (BISAC) codes used to categorize
publications based on topical content. When
uploading a publication, you need to provide a main
subject that best describes the general content and
a secondary subject that describes a more specific
category within the main subject. The complete
BISAC Subject Headings list is available free online
at http://www.bisg.org/what-we-do-0-136-bisac-
subject-headings-list-major-subjects.php.

BIC2  The Book Industry Communication (BIC2)
codes used to categorize publications based on
topical content. When uploading a publication, you
need to provide a main subject that best describes
the general content and a secondary subject that
describes a more specific category within the main
subject. The complete BIC2 list is available free online
at http://www.bic.org.uk.

checksum  A redundancy check used to guarantee
that the asset files Apple receives are correct and
complete. All content files you deliver to Apple must
include an industry-standard MD5 digest checksum.
iTunes Producer 2.9 for books automatically
generates these checksums for you. Once a book
package is received, the MD5 digest checksum
contained in the metadata file (one for each file you

send) is compared against the actual file received
by Apple. If any differences are detected between
the checksum calculated before delivery, and the
checksums calculated during delivery, iTunes
Producer 2.9 for books rejects the entire package.

CLIL  The Commission de Liaison Interprofessionnelle
due Livre (CLIL) codes used to categorize
publications based on topical content. When
uploading a publication, you need to provide a main
subject that best describes the general content and
a secondary subject that describes a more specific
category within the main subject. The complete CLIL
list is available free online at http://clil.org/informa-
tion/detailDoc.html?docId=6.

DRM free  Digital Rights Management (DRM) free
content in the iBookstore that has no usage
restrictions.

EPUB format  An electronic publication file format
(EPUB). A digital version of a printed publication,
created according to the EPUB format. The EPUB
format is a free, open eBook standard developed
and maintained by the International Digital
Publishing Forum (IDPF), a nonprofit standards
organization.

ISBN-10  The International Standard Book Number
(ISBN) is a 10-digit number that is typically used for
older physical titles. The ISBN identifies one title or
edition of a title from one specific publisher and is
unique to that edition. An EPUB file is considered an
“edition” and must have a unique ISBN number. For
more information on ISBNs, visit www.bowker.com.
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ISBN-13  The International Standard Book Number
(ISBN) is a 13-digit number that uniquely identifies
books and book-like products published
internationally. The ISBN identifies one title or edition
of a title from one specific publisher and is unique
to that edition. An EPUB file is considered an
“edition” and must have a unique ISBN number. For
more information on ISBNs, visit www.bowker.com.

iTunes Connect  A suite of web-based tools you can
use to sign up to become a book provider, to
download iTunes Producer 2.9 for books, and to
manage your content; including searching,
inspecting, and changing pricing.

iTunes Producer file  A tab-delimited file (encoded
in UTF-16 format) or spreadsheet file used to import
publication details.

iTunes Store Package  An iTunes Producer
generated file with the .itmsp file extension. iTunes
Producer 2.9 for books generates a package file from
your EPUB or Multi-Touch, cover art, screenshots,
publication information and rights and pricing, and
so on.

metadata  Supplemental information about a media
file type. For example, a file can contain information
such as the name of the person that created the file,
the length of the file, the title of the file, description,
and so on.

Multi-Touch format  A file format created for
Multi-Touch books and Multi-Touch textbooks on
the iPad. Books you create in Multi-Touch format
(.ibooks) using iBooks Author support rich
typography, precise layout, and new interactive
objects such as image galleries, quizzes, and
slideshows. See also textbook.

related products  A group of elements that
describes a product with a specific relationship (for
example, “Is special edition of”) to the publication

you are sending in the book package to the
iBookstore. You specify related products so iTunes
Producer 2.9 for books can collect information about
other publications related to the current publication.
For example, other publications in the same series
or other versions of the same publication (trade
paperback, mass market paperback, hardcover).
iTunes Producer 2.9 for books uses this information
when users search the iBookstore.

textbook  An instructional material specifically
intended for K-12 and higher education students for
the study of a particular subject. You must deliver
all textbooks in the Multi-Touch format. Currently,
textbooks are only available in the U.S. market. See
also Multi-Touch format.

scale up  Increasing the size of an image without
re-scanning or re-importing the original art.

Vendor ID  A unique numerical identifier, between
6 and 32 characters, you can use to look up your
book in iTunes Producer and iTunes Connect. By
default, iTunes Producer automatically generates
the Vendor ID. A Vendor ID is required for all books.

Glossary
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This table describes the changes to Using iTunes Producer 2.9 for Books .

NotesDate

This 2.9 release includes the following updates to iTunes Producer: parental
advisory support for books; series sequence improvements; enhanced
screenshot assets; Multi-Touch identification; plus additional
enhancements and bug fixes.

2013-02-19

This 2.8 release includes the following updates to iTunes Producer: version
information; automatically generated Vendor IDs; phonetic name support;
additional target audiences; mass territory support; plus additional
enhancements and bug fixes.

2012-10-10

This 2.7.1 release includes the following updates to iTunes Producer:
localized user interface; plus additional enhancements and bug fixes.

2012-06-26

This 2.7 release includes the following updates to iTunes Producer: import
templates; plus additional enhancements and bug fixes.

2012-06-12

This 2.6 release includes the following updates to iTunes Producer: custom
territory groups; send to Apple update; improved user interface; updated
file import; enhanced search; plus additional enhancements and bug fixes.

2012-03-13

This 2.5 release includes the following updates to iTunes Producer:
Multi-Touch format support; enhanced metadata support; updated system
requirements; plus additional enhancements and bug fixes.

2011-10-19
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NotesDate

This 2.4 release includes the following updates to iTunes Producer:
improved user interface; filtering capabilities; primary contributor role;
EPUB file validation and correction; updated system requirements; plus
additional enhancements and bug fixes.

2011-06-19

This 2.3 release includes the following updates to iTunes Producer:
enhanced metadata lookup feature; updated file import; preview file
support; improved related products; enhanced BISAC subjects; active user
button; Submit Feedback menu; Spotlight integration; plus additional
enhancements and bug fixes..

2011-02-11

This 2.2 release includes the following updates to iTunes Producer:
publication type support; more robust delivery settings; package delivery
enhancements; plus additional enhancements and bug fixes.

2010-11-10

This 2.1.2 release includes the following updates to iTunes Producer: EPUB
file validation; file import support; plus additional enhancements and bug
fixes.

2010-06-10

Apple introduces iTunes Producer 2.1 for Books, a tool to help you deliver
your books for sale in the iBookstore. You use iTunes Producer 2.1 for
Books to provide information about a publication, such as title, publisher,
date, and so on, and upload asset files.

2010-03-16

Revision History
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sales start date 35
saving 44
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MERCHANTABILITY, OR FITNESS FOR A PARTICULAR
PURPOSE.ASARESULT, THISDOCUMENT ISPROVIDED
“AS IS,” AND YOU, THE READER, ARE ASSUMING THE
ENTIRE RISK AS TO ITS QUALITY AND ACCURACY.

IN NO EVENT WILL APPLE BE LIABLE FOR DIRECT,
INDIRECT, SPECIAL, INCIDENTAL, ORCONSEQUENTIAL
DAMAGES RESULTING FROM ANY DEFECT OR
INACCURACY IN THIS DOCUMENT, even if advised of
the possibility of such damages.

THE WARRANTY AND REMEDIES SET FORTH ABOVE
ARE EXCLUSIVE AND IN LIEU OF ALL OTHERS, ORAL
OR WRITTEN, EXPRESS OR IMPLIED. No Apple dealer,
agent, or employee is authorized to make any
modification, extension, or addition to this warranty.

Some states do not allow the exclusion or limitation
of implied warranties or liability for incidental or
consequential damages, so the above limitation or
exclusion may not apply to you. This warranty gives
you specific legal rights, and youmay also have other
rights which vary from state to state.
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